Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=\s|^)([A-Za-z0-9]+[._-]?[A-Za-z0-9]+)+@([A-Za-z]+[._-]?)+\.[A-Za-z]+\b
/
g
Input 1
1
New
VALID: info@softuni-bulgaria.org, kiki@hotmail.uk, no-reply@github.com, s.peterson@mail.uu.net, info-bg@software-university.software.academy. vlad@abg.bg INVALID: --123@gmail.com, …@mail.bg, .info@info.info, _steve@yahoo.cn, mike@helloworld, mike@.unknown.soft., s.johnson@invalid-.