$re = '/^[0-9\+\-\s]{1,12}$/';
$str = '4686787787+354645666666666666884';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);