$re = '/(([A-Za-z]{3,9}:(?:\/\/)|www\.)[A-Za-z0-9.-]+((?:\/[-\+~%\/.\w_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\\\w]*))?)/i';
$str = 'www.google.com
http://www.google.com
mailto:somebody@google.com
somebody@google.com
www.url-with-querystring.com/?url=has-querystring
my text etc.:https://mywebsite.com/?query=abc0123484R4jFLE !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);