#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^([a-z0-9]+(?>-[a-z0-9]+)*?)(?:-([0-9]{4})+)?$(?<![0-9]{2}(?<!20)..)"
Local $sString = "car-audi-tt-2" & @CRLF & _
"car-audi-tt-2-2019" & @CRLF & _
"car-audi-tt-2-1919" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")