import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(?:[1-9]\\d*?|0)?(?:\\.(?:\\d*?[1-9]|0))?(?<=[\\d])$";
        final String string = "1.6\n"
	 + ".16\n"
	 + "16\n"
	 + "0.6\n"
	 + "01.6\n"
	 + "0.\n"
	 + "0\n"
	 + "0.0\n"
	 + ".0\n"
	 + ".01\n"
	 + ".001\n"
	 + "1.60\n"
	 + "100\n"
	 + "100.0001\n"
	 + "601.10\n"
	 + "601.119201\n"
	 + "1.0";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}