// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<code name=["\\]+(.*?)["\\]+>(.*?)<\\\/code>"#).unwrap();
let string = "<div>Какой-то код <code name=\\\"c+++\\\">
void main(){
cout<<\\\"heelo world\\\";
class A{
char *name;
A(char *n):namae(n);
}
}<\\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name=\"c++\">
#include <iostream>
void print(char * msg){
cout<<msg;
<\\/code>
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}