import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<code>\\+?\\d{1,3})[-\\s]{0,}(?<number>\\(?\\d{3}\\)?[-\\s]{0,}\\d{3}[-\\s]{0,}\\d{2}[-\\s]{0,}\\d{2})$";
final String string = "+447700150563\n"
+ "+14247323156\n"
+ "+12048170348\n"
+ "+33644628265\n"
+ "+78005553535\n"
+ "88005553535\n"
+ "8-800-555-35-35\n"
+ "8 800 555 35 35\n"
+ "8(800)5553535\n"
+ "8-(800)5553535\n"
+ "8-(800) 555 3535\n"
+ "8 (800) 555 3535";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}