import Foundation
let pattern = #"^\s*(importScripts\(['"]https:\/\/api\.mindbox\.ru\/scripts\/service-worker\.js['"]\));?\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
importScripts("https://api.mindbox.ru/scripts/service-worker.js");
importScripts('https://api.mindbox.ru/scripts/service-worker.js');
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}