use strict;
my $str = '49';
my $regex = qr/\b([0-9]+)\b/p;
my $subst = '$1~09876543210';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";