#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b0|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*"
Local $sString = "48"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)