const regex = /\b0|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0|([0-9])(?=0*~[0-9]*?\\1([0-9]))|~[0-9]*', 'g')
const str = `48`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);