$re = '/\b0|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*/';
$str = '48';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;