re = /\b0|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*/
str = '48'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result