const regex = /^\b[a-z0-9](?:[-._]?[a-z0-9]+)*\b@(?:[a-z0-9](?:\-?[a-z0-9]+)*\.)+[a-z]{2,}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\b[a-z0-9](?:[-._]?[a-z0-9]+)*\\b@(?:[a-z0-9](?:\\-?[a-z0-9]+)*\\.)+[a-z]{2,}$', 'i')
const str = `i@3s-d.ds`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}