$re = '/(?:^|\s)(\d{8})(?![.,@\d])/m';
$str = '11111111 12345678.1 11111112 11111113';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);