re = /.*?(?![\d.]+)(?=\w+\.\w+\.\w+)(?<RawHost>[^\s]+)/
str = 'server1 10.10.10.10 server2.atmydomain.com
server1 server3.atmydomain.com 10.10.10.10
server4.atmydomain.com 10.10.10.10 server1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end