#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$"
Local $sString = "Mark Twain" & @CRLF & _
"Michael Smith" & @CRLF & _
"New Name9012345678901234567890" & @CRLF & _
"New Name90123456789012345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")