using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$";
string input = @"Mark Twain
Michael Smith
New Name9012345678901234567890
New Name90123456789012345678901";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}