import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{3,30}$)[A-Za-z0-9]+(?:\\s[A-Za-z0-9]+)?$";
final String string = "Mark Twain\n"
+ "Michael Smith\n"
+ "New Name9012345678901234567890\n"
+ "New Name90123456789012345678901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}