const regex = /^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{3,30}$)[A-Za-z0-9]+(?:\\s[A-Za-z0-9]+)?$', 'gm')
const str = `Mark Twain
Michael Smith
New Name9012345678901234567890
New Name90123456789012345678901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}