use strict;
my $str = 'Mark Twain
Michael Smith
New Name9012345678901234567890
New Name90123456789012345678901';
my $regex = qr/^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}