#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)((On|Em)\s+(?:[0-3]?[0-9][\s,\/\.\-]*(?:(?:th)|(?:st)|(?:nd)|(?:rd))?.*?(?:(?:Jan(?:uary)?)|(?:[Jj]an(?:eiro)?)|(?:Feb(?:ruary)?)|(?:[Ff]ev(?:ereiro)?)|(?:Mar(?:ch)?)|(?:[Mm]ar(?:ço)?)|(?:Apr(?:il)?)|(?:[Aa]br(?:il)?)|(?:May)|(?:[Mm]ai(?:o)?)|(?:Jun(?:e)?)|(?:[Jj]un(?:ho)?)|(?:Jul(?:y)?)|(?:[Jj]ul(?:ho)?)|(?:Aug(?:ust)?)|(?:[Aa]go(?:sto)?)|(?:Sep(?:tember)?)|(?:[Ss]et(?:embro)?)|(?:Oct(?:ober)?)|(?:[Oo]ut(?:ubro)?)|(?:Nov(?:ember)?)|(?:[Nn]ov(?:embro)?)|(?:Dec(?:ember)?)|(?:[Dd]ez(?:embro)?)|(?:[0-1]?[0-9])).*(?:[1-2]?[0-9])[0-9][0-9][\s,\/\.\-](?:[0-2])?[0-9]:[0-5][0-9](?::[0-5][0-9])?(?:(?:\s)?[AP]M)?).*(wrote|escreveu):\s+)"
Local $sString = "Nos dois sistemas." & @CRLF & _
"" & @CRLF & _
"> ##- Não escreva abaixo desta linha -##" & @CRLF & _
">" & @CRLF & _
"> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*" & @CRLF & _
"> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25" & @CRLF & _
">" & @CRLF & _
"> *COMENTÁRIO:*" & @CRLF & _
"> Bom dia Mayla," & @CRLF & _
"> Apenas sistema Montafarma?" & @CRLF & _
"> ------------------------------" & @CRLF & _
">" & @CRLF & _
"> *ID Reporte: * #1468" & @CRLF & _
"> *Situação: * *ABERTO*" & @CRLF & _
"> *Módulo:* Produção" & @CRLF & _
"> *Tela:* ordem de pedido" & @CRLF & _
"> *Nome: * mayla.capana - MAYLA CAPANA" & @CRLF & _
"> *Emissão: * 22/05/2018 12:00:00" & @CRLF & _
"> *Fechamento: * -" & @CRLF & _
"> *Responsável: * DELTA SI" & @CRLF & _
"> *Prioridade: * Urgente" & @CRLF & _
"> *Tipo: * Ajuda" & @CRLF & _
">" & @CRLF & _
"> *MENSAGEM: *" & @CRLF & _
"> Bom dia," & @CRLF & _
">" & @CRLF & _
"> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -" & @CRLF & _
"> Ordem de Pedido. (igual a tela que a Iza tem acesso)." & @CRLF & _
">" & @CRLF & _
"> Aguardo retorno." & @CRLF & _
">" & @CRLF & _
"> Até," & @CRLF & _
">" & @CRLF & _
">"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)