import re
regex = re.compile(r"((On|Em)\s+(?:[0-3]?[0-9][\s,\/\.\-]*(?:(?:th)|(?:st)|(?:nd)|(?:rd))?.*?(?:(?:Jan(?:uary)?)|(?:[Jj]an(?:eiro)?)|(?:Feb(?:ruary)?)|(?:[Ff]ev(?:ereiro)?)|(?:Mar(?:ch)?)|(?:[Mm]ar(?:ço)?)|(?:Apr(?:il)?)|(?:[Aa]br(?:il)?)|(?:May)|(?:[Mm]ai(?:o)?)|(?:Jun(?:e)?)|(?:[Jj]un(?:ho)?)|(?:Jul(?:y)?)|(?:[Jj]ul(?:ho)?)|(?:Aug(?:ust)?)|(?:[Aa]go(?:sto)?)|(?:Sep(?:tember)?)|(?:[Ss]et(?:embro)?)|(?:Oct(?:ober)?)|(?:[Oo]ut(?:ubro)?)|(?:Nov(?:ember)?)|(?:[Nn]ov(?:embro)?)|(?:Dec(?:ember)?)|(?:[Dd]ez(?:embro)?)|(?:[0-1]?[0-9])).*(?:[1-2]?[0-9])[0-9][0-9][\s,\/\.\-](?:[0-2])?[0-9]:[0-5][0-9](?::[0-5][0-9])?(?:(?:\s)?[AP]M)?).*(wrote|escreveu):\s+)", flags=re.DOTALL)
test_str = ("Nos dois sistemas.\n\n"
"> ##- Não escreva abaixo desta linha -##\n"
">\n"
"> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*\n"
"> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25\n"
">\n"
"> *COMENTÁRIO:*\n"
"> Bom dia Mayla,\n"
"> Apenas sistema Montafarma?\n"
"> ------------------------------\n"
">\n"
"> *ID Reporte: * #1468\n"
"> *Situação: * *ABERTO*\n"
"> *Módulo:* Produção\n"
"> *Tela:* ordem de pedido\n"
"> *Nome: * mayla.capana - MAYLA CAPANA\n"
"> *Emissão: * 22/05/2018 12:00:00\n"
"> *Fechamento: * -\n"
"> *Responsável: * DELTA SI\n"
"> *Prioridade: * Urgente\n"
"> *Tipo: * Ajuda\n"
">\n"
"> *MENSAGEM: *\n"
"> Bom dia,\n"
">\n"
"> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -\n"
"> Ordem de Pedido. (igual a tela que a Iza tem acesso).\n"
">\n"
"> Aguardo retorno.\n"
">\n"
"> Até,\n"
">\n"
">")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)