$re = '/([a-zA-Z \\\\])|[^a-zA-Z \\\\]/m';
$str = 'abc Abc aBC cde123 def-ghi $?!123';
$subst = "\L\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;