import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{5}\\b";
final String string = "X test 1 test 1234 test; no output\n"
+ "V test 1 12345 test\n"
+ "X test 123456 test 12 test\n"
+ "V 12394 test\n"
+ "V 84725";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}