package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]+)\s*(.*?)\.\s(.*?)(?:\s*([0-9]+))?$`)
var str = `8 EXT./INT. MONORAIL - MORNING 8
9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS 9
9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}