# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(http.*)//gm;t' <<< "http://www.mylink.com
http://example.com
https://www.example.net"