#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(http.*)"
Local $sString = "http://www.mylink.com" & @CRLF & _
"http://example.com" & @CRLF & _
"https://www.example.net"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)