# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^A-Z]+//gm;t' <<< "01. A little love (2002)
02 - No.1 Star
03 Love Story"