#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^A-Z]+"
Local $sString = "01. A little love (2002)" & @CRLF & _
"02 - No.1 Star" & @CRLF & _
"03 Love Story"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)