$re = '/^[^A-Z]+/m';
$str = '01. A little love (2002)
02 - No.1 Star
03 Love Story';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;