using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z](?:[\s\S]*?[^\\]$)?";
string substitution = @"<pre>$0</pre>";
string input = @"npm i --save \
gulp \
express \
forever
echo hi
a";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}