const regex = /^[A-Za-z](?:[\s\S]*?[^\\]$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z](?:[\\s\\S]*?[^\\\\]$)?', 'gm')
const str = `npm i --save \\
gulp \\
express \\
forever
echo hi
a`;
const subst = `<pre>$0</pre>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);