use strict;
my $str = 'npm i --save \\
gulp \\
express \\
forever
echo hi
a';
my $regex = qr/^[A-Za-z](?:[\s\S]*?[^\\]$)?/mp;
my $subst = '<pre>$0</pre>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";