// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z](?:[\s\S]*?[^\\]$)?").unwrap();
let string = "npm i --save \\
gulp \\
express \\
forever
echo hi
a";
let substitution = "<pre>$0</pre>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}