using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Time in seconds =\s*([^\n]*)";
string input = @"Class = C
Size = 162x 162x 162
Iterations = 200
Time in seconds = 23.68
Total processes = 900
Compiled procs = 900
Mop/s total = 121032.40
Mop/s/process = 134.48";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}