#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}"
Local $sString = "Block1 {" & @CRLF & _
"" & @CRLF & _
" block1child1 {" & @CRLF & _
" test1" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" block1child2 {" & @CRLF & _
" test2" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" block1child3 {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Block2 {" & @CRLF & _
"" & @CRLF & _
" block2child1 {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" block2child2 {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")