use strict;
my $str = 'Block1 {
block1child1 {
test1
}
block1child2 {
test2
}
block1child3 {
}
}
Block2 {
block2child1 {
}
block2child2 {
}
}';
my $regex = qr/([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}/simp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}