import re
regex = re.compile(r"([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}", flags=re.DOTALL | re.IGNORECASE | re.MULTILINE)
test_str = ("Block1 {\n\n"
" block1child1 {\n"
" test1\n"
" }\n\n"
" block1child2 {\n"
" test2\n"
" }\n\n"
" block1child3 {\n\n"
" }\n"
"}\n\n"
"Block2 {\n\n"
" block2child1 {\n\n"
" }\n\n"
" block2child2 {\n\n"
" }\n\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")