#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{2,3}|\d{1,3}(?:,\d{3})+)(?:,\d{3})+$"
Local $sString = "10,400,000" & @CRLF & _
"10,900,000" & @CRLF & _
"500,000" & @CRLF & _
"" & @CRLF & _
"10,000" & @CRLF & _
"100,000" & @CRLF & _
"1,000,000" & @CRLF & _
"10,000,000" & @CRLF & _
"100,000,000" & @CRLF & _
"1,000,000,000" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"1,0" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1,000" & @CRLF & _
"10,00" & @CRLF & _
"10000" & @CRLF & _
"100,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")