#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)("SystemID":\s*"[A-Z0-9]+")"
Local $sString = "{" & @CRLF & _
" "EmployeeData": [" & @CRLF & _
" {" & @CRLF & _
" "SystemID": "U6JDD"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SystemID": """ & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SystemID": null" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")