using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'Year'(?:[2][0]|[1][9])(?:[0-9]{2,2}))(?'Month'(?:[0][1-9]|[1][0-2]))(?'Day'[0-2][1-9]|[3][0-1]|[1,2][0])$";
string input = @"20210112";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}