package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$`)
var str = `0674420606
06 74 42 06 06
06/74/42/06/06
06-74-42-06-06
06.74.42.06.06
+33674420606
+330674420606
+33 6 74 42 06 06
(+33)674420606
(+33) 674420606
+33 0674420606
// ^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$
// [^\d+]
// ^[^\d]?(\+?\d\d)?0?([1-9])((?:\d\d){4})$
// ^\+?\+?\d\d?0?[1-9](?:\d\d){4}$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}