// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$").unwrap();
let string = "0674420606
06 74 42 06 06
06/74/42/06/06
06-74-42-06-06
06.74.42.06.06
+33674420606
+330674420606
+33 6 74 42 06 06
(+33)674420606
(+33) 674420606
+33 0674420606
// ^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})$
// [^\\d+]
// ^[^\\d]?(\\+?\\d\\d)?0?([1-9])((?:\\d\\d){4})$
// ^\\+?\\+?\\d\\d?0?[1-9](?:\\d\\d){4}$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}