package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/users/[^/]+/?$`)
var str = `/users/akinuri/
/users/akinuri
/users/akinuri/asd/
/foo/b/ar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}