$re = '~^/users/[^/]+/?$~m';
$str = '/users/akinuri/
/users/akinuri
/users/akinuri/asd/
/foo/b/ar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);