re = /^\/users\/[^\/]+\/?$/m
str = '/users/akinuri/
/users/akinuri
/users/akinuri/asd/
/foo/b/ar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end