// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\p{L}]+(?:\s[\p{L}]+)*$").unwrap();
let string = "GEÇERLİ
ÖMER
ENES SEFA
ENES SEFA KÜCCÜK
ŞEYDA
İÇçiöşŞğĞ
GEÇERSİZ
1enes se
.dsds
enes dsdsd
öçds12
dd2sds";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}