import Foundation
let pattern = #"(?i).*<br>Name:(.*)\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|:\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<br><br>Name:Adı Soyadı <br>\r\n ◀
E-Mail: <a href="mailto:1denememail@hotmail.com" target="_blank">1denememail@hotmail.com</a> <br>\r\n
Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1
This regex was created by ~~Barış Yılmaz~~
asdf
asadasdasd
asdasdasdf
<br>
https://wmaraci.com/forum/
<br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)