use strict;
my $str = 'a=123 344=555
a=1 b=2 c=3
delim=; trst=.... c=3
delim=; trst=".... " c=3
x=12 abc="asdasda"
x12 abc="asdasda"
x13 xddss=\'asdasda\'
x13=213 xddss=\'asdasda\'
adas=123 123=312312 x="dasdas asd as as das das das das das" as="adsasdas"
adas=123 123=312312 x="dasdas asd as as = das das das das das" as="adsasdas"
adas=123 123=312312 x=\'dasdas asd as as das das das das das\' as=\'adsasdas\'
adas=123 123=312312 x=\'dasdas asd as as = das das das das das\' as=\'adsasdas\'';
my $regex = qr/(?|([a-zA-Z0-9]+)=(?|([^\v '"]+)|"(.*?)"|'(.*?)')|([a-zA-Z0-9]+))/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}